EFAX Service Disruption

Incident Report for T3 Communications

Monitoring

Issue impacting T3 Fax services have been resolved, we are seeing normal fax completion at this time. Engineering continues to monitor.
Posted Mar 23, 2023 - 17:20 EDT

Update

T3 Engineering is currently working to resolve further issue impacting T3 EFAX services. Database issues that had caused an outage have been resolved, however service is still intermittent until we are able to call and on clear on all issues being rectified.
Posted Mar 23, 2023 - 10:31 EDT

Identified

T3 Engineering is currently working to resolve an issue impacting T3 EFAX services. The issue has been isolated and is currently being worked by Engineering to restore full functionality.
Posted Mar 19, 2023 - 11:44 EDT
This incident affects: VoIP Services.